【漏洞预警】Strapi多个安全漏洞

2023-04-25 7,548

1. 通告信息

近日,安识科技A-Team团队监测到Strapi发布安全公告,修复了Strapi中的多个漏洞,可组合利用CVE-2023-22621和CVE-2023-22894在Strapi <=4.5.5上实现未经身份验证的远程代码执行。目前这些漏洞的细节及部分漏洞的PoC/EXP已经公开披露。
对此,安识科技建议广大用户及时升级到安全版本,并做好资产自查以及预防工作,以免遭受黑客攻击。


2. 漏洞概述

漏洞名称:Strapi多个安全漏洞
简述:Strapi 是一个流行的 Node.js 内容管理框架(headless-CMS),可轻松构建强大的 API。Strapi中存在多个安全漏洞,可组合利用CVE-2023-22621和CVE-2023-22894在Strapi <=4.5.5上实现未经身份验证的远程代码执行。
CVE-2023-22621:Strapi服务器端模板注入漏洞(严重)
Strapi 版本<= 4.5.5中存在经过身份验证的服务器端模板注入(SSTI)漏洞,有权访问 Strapi 管理面板的远程威胁者可以将恶意Payload注入到电子邮件模板中,绕过本应阻止代码执行的验证检查,从而在服务器上执行任意代码。
CVE-2023-22894:Strapi信息泄露漏洞(严重)
Strapi 版本< 4.8.0中存在信息泄露漏洞,有权访问管理面板的威胁者可以通过利用查询过滤器来发现敏感的用户详细信息,如Strapi 管理员和 API 用户。可利用该漏洞劫持Strapi管理员账户,并通过泄露密码重置令牌和更改管理员密码来获得未经授权的 Strapi 超级管理员访问权限。
CVE-2023-22893:Strapi身份验证绕过漏洞(高危)
Strapi 版本< 4.6.0中,当使用AWS Cognito login provider用于身份验证时,Strapi不会验证在OAuth 流程期间发出的访问或ID令牌。远程威胁者可以伪造使用 "None"类型算法签名的ID令牌,以绕过身份验证并冒充任何使用AWS Cognito login provider进行身份验证的用户。


3. 漏洞危害

攻击者可利用以上漏洞实现未经身份验证的远程代码执行。


4. 影响版本

目前受影响的Strapi 版本版本:
CVE-2023-22621:Strapi 版本<= 4.5.5
CVE-2023-22894:3.2.1<= Strapi 版本< 4.8.0
CVE-2023-22893:3.2.1<= Strapi 版本< 4.6.0


5. 解决方案

目前这些漏洞已经修复,受影响用户可升级到以下版本(或当前最新版本):
CVE-2023-22621:Strapi 版本 >=4.5.6
CVE-2023-22894:Strapi 版本 >=4.8.0
CVE-2023-22893:Strapi 版本 >=4.6.0
下载链接:
https://github.com/strapi/strapi/releases


6. 时间轴

-】2023年0423 安识科技A-Team团队监测到漏洞公布信息
-】2023年04月24日 安识科技A-Team团队根据漏洞信息分析
-】2023年04月25日 安识科技A-Team团队发布安全通告
       

本文作者:安识科技

本文为安全脉搏专栏作者发布,转载请注明:https://www.secpulse.com/archives/199607.html

Tags:
评论  (0)
快来写下你的想法吧!

安识科技

文章数:190 积分: 135

安识科技:专业的企业安全解决方案提供商。官网:https://www.duoyinsu.com/

安全问答社区

安全问答社区

脉搏官方公众号

脉搏公众号