【漏洞预警】Linux kernel释放后使用漏洞

2023-03-17 7,055

1. 通告信息



近日,安识科技A-Team团队监测到Red Hat官方发布安全公告,披露了Linux kernel中一个可能导致释放后使用的漏洞(CVE-2023-28466)。
对此,安识科技建议广大用户及时升级到安全版本,并做好资产自查以及预防工作,以免遭受黑客攻击。


2. 漏洞概述



CVE:CVE-2023-28466
漏洞名称:Linux kernel释放后使用漏洞
简述:Linux Kernel 是开源操作系统 Linux 所使用的内核。
由于Linux kernel 版本<=6.2.6中的net/tls/tls_main.c中的 do_tls_getsockopt 缺少 lock_sock 调用,导致竞争条件,可能导致释放后使用或NULL 指针取消引用。


3. 漏洞危害



do_tls_getsockopt 缺少 lock_sock 调用,导致竞争条件,可能导致释放后使用或NULL 指针取消引用。


4. 影响版本



目前受影响的Linux kernel版本:
Linux kernel <= 6.2.6


5. 解决方案



目前该漏洞已经修复,受影响用户可及时安装补丁。
补丁链接:
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit?id=49c47cc21b5b7a3d8deb18fc57b0aa2ab1286962


6. 时间轴



-】2023年03月15日 安识科技A-Team团队监测到漏洞公布信息
-】2023年03月16日 安识科技A-Team团队根据漏洞信息分析
-】2023年03月17日 安识科技A-Team团队发布安全通告

本文作者:安识科技

本文为安全脉搏专栏作者发布,转载请注明:https://www.secpulse.com/archives/197852.html

Tags:
评论  (0)
快来写下你的想法吧!

安识科技

文章数:190 积分: 135

安识科技:专业的企业安全解决方案提供商。官网:https://www.duoyinsu.com/

安全问答社区

安全问答社区

脉搏官方公众号

脉搏公众号