【漏洞预警】GitLab远程代码执行漏洞

2022-08-25 5,537


1. 通告信息




近日,安识科技A-Team团队监测到一则 GitLab组件存在远程代码执行漏洞的信息,漏洞编号:CVE-2022-2884,漏洞威胁等级:高危。

当用户已经通过登录认证时,攻击者可利用该漏洞通过 GitHub API 构造恶意数据执行远程代码攻击,最终获取服务器最高权限。

对此,安识科技建议广大用户及时升级到安全版本,并做好资产自查以及预防工作,以免遭受黑客攻击。


2. 漏洞概述




CVECVE-2022-2884

简述:GitLab 是美国 GitLab 公司的一款使用 Ruby on Rails 开发的、自托管的、Git (版本控制系统)项目仓库应用程序。该程序可用于查阅项目的文件内容、提交历史、Bug 列表等。GitLab 主要对 group 和 project 两个维度进行代码和文档管理。其中 group 是群组,project 是工程项目,一个 group 可以管理多个 project,可以理解为一个群组中有多项软件开发任务;而一个 project中可能包含多个 branch,意为每个项目中有多个分支,分支间相互独立,不同分支可以进行归并。当用户已经通过登录认证时,攻击者可利用该漏洞通过 GitHub API 构造恶意数据执行远程代码攻击,最终获取服务器最高权限。


3. 漏洞危害




攻击者可利用该漏洞通过 GitHub API 构造恶意数据执行远程代码攻击,最终获取服务器最高权限。


4. 影响版本




目前受影响的 GitLab 版本:

11.3.4 ≤ GitLab CE/EE < 15.1.5

15.2 ≤ GitLab CE/EE < 15.2.3

15.3 ≤ GitLab CE/EE < 15.3.1


5. 解决方案




当前官方已发布最新版本,建议受影响的用户及时更新升级到最新版本。链接如下:https://about.gitlab.com/update/


6. 时间轴




-202208月23日 安识科技A-Team团队监测到GitLab官方发布安全通告

-2022年08月24日 安识科技A-Team团队根据漏洞信息分析

-2022年08月25日 安识科技A-Team团队发布安全通告


本文作者:安识科技

本文为安全脉搏专栏作者发布,转载请注明:https://www.secpulse.com/archives/186301.html

Tags:
评论  (0)
快来写下你的想法吧!

安识科技

文章数:159 积分: 135

安识科技:专业的企业安全解决方案提供商。官网:https://www.duoyinsu.com/

安全问答社区

安全问答社区

脉搏官方公众号

脉搏公众号