Apache Druid 远程代码执行漏洞(CVE-2021-25646)

2021-02-02 6,893


1. 通告信息


20210201日,安识科技A-Team团队监测到Apache Druid官方发布安全更新,通报了一个远程代码执行漏洞,该漏洞编号为CVE-2021-25646,漏洞等级:高危由于 Apache Druid 默认情况下缺乏授权认证,攻击者可直接构造恶意请求执行任意代码

 

2. 漏洞概述


Apache Druid包括执行用户提供的JavaScript的功能嵌入在各种类型请求中的代码。此功能在用于高信任度环境中,默认已被禁用。但是,在Druid 0.20.0及更低版本中,经过身份验证的用户发送恶意请求,利用Apache Druid漏洞可以执行任意代码。


3. 漏洞危害


攻击者可直接构造恶意请求执行任意代码控制服务器

 

4. 影响版本


Apache Druid < 0.20.1

 

5. 解决方案


安识科技建议广大用户及时更新Apache Druid,下载链接为:https://druid.apache.org/downloads.html

https://github.com/apache/druid/releases/tag/druid-0.20.1

 

6. 时间轴 


-202101月29 RedHat官方发布更新通告

-20210201 安识科技A-Team团队根据通告内容进行分析

-20210201 安识科技A-Team团队发布安全通告




本文作者:安识科技

本文为安全脉搏专栏作者发布,转载请注明:https://www.secpulse.com/archives/152981.html

Tags:
评论  (0)
快来写下你的想法吧!

安识科技

文章数:72 积分: 135

安识科技:专业的企业安全解决方案提供商。官网:https://www.duoyinsu.com/

安全问答社区

安全问答社区

脉搏官方公众号

脉搏公众号