漏洞情报|Node.js通过DNS请求实现拒绝服务漏洞风险通告(CVE-2020-8277)

2020-11-17 5,104

近日,腾讯云安全运营中心监测到Node.js 官方发布安全更新,修复了一个拒绝服务漏洞(漏洞编号:CVE-2020-8277),攻击者可通过DNS请求来触发拒绝服务

为避免您的业务受影响,腾讯云安全建议您及时开展安全自查,如在受影响范围,请您及时进行更新修复,避免被外部攻击者入侵。

漏洞详情

受影响版本的 Node.js 应用程序允许攻击者对其选择的主机触发DNS请求,攻击者可通过使该应用程序解析具有大量响应的DNS记录来触发拒绝服务。

风险等级

高风险

漏洞风险

攻击者可通过触发大量DNS请求来实现拒绝服务。

影响版本

Node.js 12.x 系列:12.16.3-12.19.1

Node.js 14.x系列:14.13.0-14.15.1

Node.js 15.x系列全部版本

安全版本

Node.js v12.19.1(LTS)

Node.js v14.15.1(LTS)

Node.js v15.2.1(当前)

修复建议

官方已发布安全版本,检查您的Node.js是否在受影响版本范围,如受影响,请你选择合理时间进行升级操作,升级到安全版本,避免影响业务。

下载链接:

    https://nodejs.org/en/blog/release/v12.19.1/

    https://nodejs.org/en/blog/release/v14.15.1/

    https://nodejs.org/en/blog/release/v15.2.1/

【备注】:建议您在升级前做好数据备份工作,避免出现意外

漏洞参考

https://nodejs.org/en/blog/vulnerability/november-2020-security-releases/



本文作者:云鼎实验室

本文为安全脉搏专栏作者发布,转载请注明:https://www.secpulse.com/archives/146557.html

Tags:
评论  (0)
快来写下你的想法吧!

云鼎实验室

文章数:45 积分: 164

我们正努力成为云上安全的技术领导者~

安全问答社区

安全问答社区

脉搏官方公众号

脉搏公众号